VCOM:VectorWorks:ISDK::WSAddTool: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Adds a tool definition to the master list of tools within a workspace.


@param inToolIdentifier the tool we are adding to the workspace.

@param inShortcutKey the shortcut key to activate the tool.

@param inKeyModifiers the shortcut key modifiers that are used in combination with the shortcut key to active this tool.

@return true if the operation was successful.

virtual bool WSAddTool(
long inWorkspaceReference,
const TXString& inToolIdentifier,
char inShortcutKey,
Uint32 inKeyModifiers)

Parameters

long inWorkspaceReference No information available.
constTXString& inToolIdentifier No information available.
char inShortcutKey No information available.
Uint32 inKeyModifiers No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009