VCOM:VectorWorks:ISDK::TaggedDataCreate

From Vectorworks Developer
Revision as of 15:07, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates an Aux list data container node attached to inOwner. 'dataContainer' is a unique four char ID . An array of 'numDataElements' of type 'dataType' is created. The array is then accessable in inOwner's at <dataContainer, dataType, dataTag>

virtual bool TaggedDataCreate(
MCObjectHandle inOwnerObj,
OSType dataContainer,
int dataType,
int dataTag,
int numDataElements)

Parameters

MCObjectHandle inOwnerObj No information available.
OSType dataContainer No information available.
int dataType No information available.
int dataTag No information available.
int numDataElements No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009