VCOM:VectorWorks:ISDK::ShowWorksheetDialog: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Displays the specified worksheet dialog for the topmost visible worksheet (if any). Worksheet dialogs that set attributes act on the worksheet's current selection.


Dialogs constants:

kWSColumnWidthDialog = 0

kWSCellBorderDialog = 1

kWSCellNumberFormatDialog = 2

kWSPreferencesDialog = 3

kWSPageSetupDialog = 4

kWSPrintDialog = 5

kWSFunctionDialog = 6

kWSCriteriaDialog = 7

kWSTextFormatDialog = 8

kWSSetRowCriteriaDialog = 9

kWSEditRowCriteriaDialog = 10

virtual void ShowWorksheetDialog(
short dialogType)

Parameters

short dialogType No information available.

Version

Availability: from Vectorworks 2009