VCOM:VectorWorks:ISDK::SetSavedSetting: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
constTXString&
const TXString&
category
category
No information available.
A category name for the setting to be stored.
</line>
</line>
<line>
<line>
constTXString&
const TXString&
setting
setting
No information available.
The name of the setting to be stored.
</line>
</line>
<line>
<line>
constTXString&
const TXString&
value
value
No information available.
The value of the setting to be stored.
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
The values are stored in an XML file. A "/" in "category" can be used as a hierarchy separator to store values in a structured way.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 50: Line 56:
[[Category:VCOM:VectorWorks:ISDK|SetSavedSetting]]
[[Category:VCOM:VectorWorks:ISDK|SetSavedSetting]]
[[Category:VCOM:VectorWorks:ISDK(Utility)|SetSavedSetting]]
[[Category:VCOM:VectorWorks:ISDK(Utility)|SetSavedSetting]]
== See also ==
[[VCOM:VectorWorks:ISDK::GetSavedSetting|GetSavedSetting]]

Latest revision as of 14:47, 5 December 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Writes a value to the saved settings file.

virtual void SetSavedSetting(
const TXString& category,
const TXString& setting,
const TXString& value)

Parameters

const TXString& category A category name for the setting to be stored.
const TXString& setting The name of the setting to be stored.
const TXString& value The value of the setting to be stored.

Remarks

The values are stored in an XML file. A "/" in "category" can be used as a hierarchy separator to store values in a structured way.

Version

Availability: from Vectorworks 2009


See also

GetSavedSetting