VCOM:VectorWorks:ISDK::PlaceSymbolN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:ISDK]]
Member of [[VCOM:VectorWorks:ISDK]]


Places an instance of the symbol &lt;definition&gt; at the specified location, rotated by &lt;rotation&gt; degrees.  If definition is nil, PlaceSymbol does nothing.</desc>
Places an instance of the symbol &lt;definition&gt; at the specified location, rotated by &lt;rotation&gt; degrees.  If definition is nil, PlaceSymbol does nothing.
 
PlaceSymbolN creates the symbol but does not insert it into the document. </desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 18:12, 20 October 2016

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Places an instance of the symbol <definition> at the specified location, rotated by <rotation> degrees. If definition is nil, PlaceSymbol does nothing.

PlaceSymbolN creates the symbol but does not insert it into the document.

virtual MCObjectHandle PlaceSymbolN(
MCObjectHandle definition,
const WorldPt& location,
double_param rotation = 0.0)

Parameters

MCObjectHandle definition No information available.
const WorldPt& location No information available.
double_param rotation=0.0 No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009