VCOM:VectorWorks:ISDK::IntersectSolid: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Result was incorrect, error does not return 0 but one of the other codes. Succes returns 0! Added some extra info.)
 
(One intermediate revision by one other user not shown)
Line 10: Line 10:
Member of [[VCOM:VectorWorks:ISDK]]
Member of [[VCOM:VectorWorks:ISDK]]


 
Will create a new solid that is the intersection of two solids (Obj1 and Obj2).
* Obj1 and Obj2 will be removed on succes.
* Obj1 and Obj2 needs to be solids, 3D polylines will return 20 (Bad input).


</desc>
</desc>
Line 27: Line 29:
MCObjectHandle
MCObjectHandle
obj1
obj1
No information available.
The first solid.
</line>
</line>
<line>
<line>
MCObjectHandle
MCObjectHandle
obj2
obj2
No information available.
The second solid.
</line>
</line>
<line>
<line>
MCObjectHandle&
MCObjectHandle&
newSolid
newSolid
No information available.
The intersection result.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 46:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
On error returns: 0</return>
{| class="wikitable"
|-
! Operation Result !! Result Code
|-
| Success || 0
|-
| Null geometry error || 1
|-
| Geometry error || 2
|-
| Out of memory error || 4
|-
| Bad group error || 5
|-
| Invalid object type || 6
|-
| Bad input || 20
|}
 
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 07:20, 29 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Will create a new solid that is the intersection of two solids (Obj1 and Obj2).

  • Obj1 and Obj2 will be removed on succes.
  • Obj1 and Obj2 needs to be solids, 3D polylines will return 20 (Bad input).
virtual short IntersectSolid(
MCObjectHandle obj1,
MCObjectHandle obj2,
MCObjectHandle& newSolid)

Parameters

MCObjectHandle obj1 The first solid.
MCObjectHandle obj2 The second solid.
MCObjectHandle& newSolid The intersection result.

Return Value

Operation Result Result Code
Success 0
Null geometry error 1
Geometry error 2
Out of memory error 4
Bad group error 5
Invalid object type 6
Bad input 20

Version

Availability: from Vectorworks 2009