VCOM:VectorWorks:ISDK::GetWorksheetCellTextFormat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:05, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the specified worksheet cell's text format.


Text Format (style) constants:

kTextStylePlain = 0

kTextStyleBold = 1

kTextStyleItalic = 2

kTextStyleUnderline = 4

kTextStyleOutline = 8

kTextStyleShadow = 16


Note: Outline and Shadow only display on the Mac

virtual void GetWorksheetCellTextFormat(
MCObjectHandle worksheet,
const Point& cell,
short& fontIndex,
short& size,
short& style)

Parameters

MCObjectHandle worksheet No information available.
constPoint& cell No information available.
short& fontIndex No information available.
short& size No information available.
short& style No information available.

Version

Availability: from Vectorworks 2009