VCOM:VectorWorks:ISDK::GetMesh: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 62: Line 62:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from Vectorworks 2022
Availability: from Vectorworks 2015


</version>
</version>

Latest revision as of 03:47, 4 March 2022

Description

namespace

Member of VCOM:VectorWorks:ISDK

GetMesh only works for kMeshNode objects. It doesn't work for solids.

virtual bool VCOM_CALLTYPE GetMesh(
MCObjectHandle hMesh,
IMeshData** outMeshData) = 0;

Parameters

hMesh MCObjectHandle A handle of kMeshNode objects
outMeshData IMeshData** no info.

Example

// meshH is a handle of kMeshNode objects
Handle meshH;

...

VectorWorks::IMeshDataPtr	thisMesh;
bool isGetMesh = gSDK->GetMesh( meshH, & thisMesh );

Version

Availability: from Vectorworks 2015