VCOM:VectorWorks:ISDK::GetExtrudeValues: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:04, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Given a handle to and extrude or a multiple extrude, returns the top and bottom surfaces in entity space. To convert a 2D defining point to it's 3D world space equivalent on the bottom of the extrude, add the bottom value as the z-value of the point and then multiply this 3D point by the entity matrix.

virtual void GetExtrudeValues(
MCObjectHandle h,
WorldCoord& bottom,
WorldCoord& top)

Parameters

MCObjectHandle h No information available.
WorldCoord& bottom No information available.
WorldCoord& top No information available.

Version

Availability: from Vectorworks 2009