VCOM:VectorWorks:ISDK::GetDLComponentPenColors: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:00, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the fore and back colors of the left and right side pens of component at index in the Double Line Preferences.

virtual CBbool GetDLComponentPenColors(
Sint16 index,
ColorRef &leftPenForeColor,
ColorRef &leftPenBackColor,
ColorRef &rightPenForeColor,
ColorRef &rightPenBackColor)

Parameters

Sint16 index No information available.
ColorRef &leftPenForeColor No information available.
ColorRef &leftPenBackColor No information available.
ColorRef &rightPenForeColor No information available.
ColorRef &rightPenBackColor No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009