VCOM:VectorWorks:ISDK::CreateSweepN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:00, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates and returns a handle to a new sweep entity. You may add objects to the definition either by using AddObjectToContainer, InsertObjectBefore, or InsertObjectAfter or by calling EnterContainer on the returned handle. [See the manual entries for these functions for more details.]. The sweep matrix defaults to the identity matrix (top view, no rotation).

virtual MCObjectHandle CreateSweepN(
double_param startAngle,
double_param arcAngle,
double_param incrAngle,
WorldCoord screwDist)

Parameters

double_param startAngle No information available.
double_param arcAngle No information available.
double_param incrAngle No information available.
WorldCoord screwDist No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009