VCOM:VectorWorks:ISDK::CreateShaderRecord

From Vectorworks Developer
Revision as of 15:00, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a shader record of the desired family (1 = color, 2 = reflectivity, 3 = transparency, 4 = bump) and prototype (constants depend on family value).

virtual MCObjectHandle CreateShaderRecord(
MCObjectHandle texture,
long family,
long prototype)

Parameters

MCObjectHandle texture No information available.
long family No information available.
long prototype No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009