VCOM:VectorWorks:ISDK::CreateRoundWall

From Vectorworks Developer
Revision as of 15:00, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a round wall whose arc spans from startPt to endPt and contains ptOnArc with the specified thickeness. If the thickness is zero, the default wall thickness will be used.

virtual MCObjectHandle CreateRoundWall(
const WorldPt& startPt,
const WorldPt& ptOnArc,
const WorldPt& endPt,
WorldCoord wallThickness = 0)

Parameters

constWorldPt& startPt No information available.
constWorldPt& ptOnArc No information available.
constWorldPt& endPt No information available.
WorldCoordwallThickness= 0 No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009