VCOM:VectorWorks:ISDK::CreateArcN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:59, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a new arc object as the topmost object in the current layer. The arc is a portion of the oval defined by the rectangle bounds. startAngle and endAngle are in degrees, with 0 degrees; being east and moving counterclockwise. Returns a handle to the new arc object.

virtual MCObjectHandle CreateArcN(
const WorldRect& bounds,
double_param startAngle,
double_param sweepAngle)

Parameters

constWorldRect& bounds No information available.
double_param startAngle No information available.
double_param sweepAngle No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009