VCOM:VectorWorks:ISDK::CalcSurfaceArea: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 10: Line 10:
Member of [[VCOM:VectorWorks:ISDK]]
Member of [[VCOM:VectorWorks:ISDK]]


Calculates the surface area of a solid or object that can be a solid. If there is a problem or the object is not a valid solid, it returns 0.0.  This function is being obsoleted.  Use ObjSurfaceArea instead.</desc>
Calculates the surface area of a solid or object that can be a solid. Return value is in '''document length units (squared)'''. If there is a problem or the object is not a valid solid, it returns 0.0.  This function is being obsoleted.  Use [[VCOM:VectorWorks:ISDK::ObjSurfaceArea]] instead to get document area units or [[VCOM:VectorWorks:ISDK::ObjSurfaceAreaInWorldCoords]] to get squared WorldCoords.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 15:16, 30 August 2022

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Calculates the surface area of a solid or object that can be a solid. Return value is in document length units (squared). If there is a problem or the object is not a valid solid, it returns 0.0. This function is being obsoleted. Use VCOM:VectorWorks:ISDK::ObjSurfaceArea instead to get document area units or VCOM:VectorWorks:ISDK::ObjSurfaceAreaInWorldCoords to get squared WorldCoords.

virtual double_gs CalcSurfaceArea(
MCObjectHandle h)

Parameters

MCObjectHandle h No information available.

Return Value

On error returns: 0.0

Version

Availability: from Vectorworks 2009