VCOM:VectorWorks:ISDK::AddCoordMoveObject2D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:59, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Use this callback before you apply a 2D move to an object. Internally, this undo technique uses less memory than an AddBothSwapObjs call because it only saves the delta, not a copy of the entire object. Passing a nil handle creates undo primitives for all selected objects.

virtual bool AddCoordMoveObject2D(
MCObjectHandle h,
WorldCoord dx,
WorldCoord dy)

Parameters

MCObjectHandle h No information available.
WorldCoord dx No information available.
WorldCoord dy No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009