VCOM:VectorWorks:IFCLib:IIFCSupport::WS FillCOBieFixedWorksheets

From Vectorworks Developer
Revision as of 14:43, 5 April 2018 by KGoranov (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Fills a worksheet with COBie data.

VCOMError WS_FillCOBieFixedWorksheets(
MCObjectHandle worksheet,
bool bIsRolledUp);

Parameters

worksheet MCObjectHandle Handle to worksheet
bIsRolledUp bool Boolean not used.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

This function fills worksheets with COBie data. In order to get the acurate result the correct handle to worksheet must be provided. In order to fully understand what is COBie and how this function operates please follow the links provided in the See Also section. This function only works with the following Preformatted worksheets:

COBieContact Worksheet COBieContact Help Worksheet COBieFacility Worksheet COBieFacility Help Worksheet COBieFloor Worksheet COBieFloor Help Worksheet COBieAttribute Worksheet COBieAttribute Help Worksheet COBieSystem Worksheet COBieSystem Help Worksheet

They can be found in the default content in the following file: Defaults >> Reports_Schedules >> COBie.vwx .

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.