VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Sets the value of entity property.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
<line>
<line>
instancePropertyValue
instancePropertyValue
TXString
TXString
no info.
The parameter must be in following syntax: "<entity_name>.<property_name>=<value>".
</line>
</line>
<line>
<line>
outSetValue
outSetValue
TXString
TXString
no info.
Ooutput parameter and it contains the result.
</line>
</line>
</lineList>
</lineList>
Line 51: Line 51:
</line>
</line>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_False
Bad VCOM instance used to call the function.
Bad VCOM instance used to call the function.
</line>
</line>
Line 76: Line 76:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017
</version>
</version>



Revision as of 13:32, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the value of entity property.

VCOMError IFC_SetIFCProperty(
MCObjectHandle hObject,
const TXString& instancePropertyValue,
TXString& outSetValue);

Parameters

hObject MCObjectHandle Handle to the object.
instancePropertyValue TXString The parameter must be in following syntax: "<entity_name>.<property_name>=<value>".
outSetValue TXString Ooutput parameter and it contains the result.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_False Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017