VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsIFCRecord

From Vectorworks Developer
Revision as of 08:55, 23 January 2018 by Sasha (talk | contribs) (Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- ...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Check if the record is IFC/COBie record.

bool IFC_IsIFCRecord(
MCObjectHandle hRecord);

Parameters

hRecord MCObjectHandle Handle to a record.

Return Value

The function returns TRUE if the record is IFC/COBie record. Otherwise returns FALSE.

Remarks

Use this function via global pointer gIFC.

Version

Available from Vectorworks 2019.