VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropertiesList: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns the list of members for an IFC entity
</desc>
</desc>


Line 25: Line 25:
scheme
scheme
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIFCSupportSchema]]
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIFCSupportSchema]]
no info.
IFC Scheme. Possible values are <b>kIFCSupportScheme_2x2</b> (IFC 2x2); <b>kIFCSupportScheme_2x3</b> (IFC 2x3) and <b>kIFCSupportScheme_2x4</b> (IFC 4).
</line>
</line>
<line>
<line>
strIfcObjName
strIfcObjName
TXString
TXString
no info.
IFC entity name.
</line>
</line>
<line>
<line>
outArrProperties
outArrProperties
TXStringArray
TXStringArray
no info.
Returns list of entity members.
</line>
</line>
<line>
<line>
outArrDefaultValues
outArrDefaultValues
TXStringArray
TXStringArray
no info.
Returns list of default values for entity members. Currently returning empty list.  
</line>
</line>
</lineList>
</lineList>
Line 81: Line 81:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2016.
</version>
</version>



Revision as of 11:05, 19 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the list of members for an IFC entity

VCOMError IFC_GetPropertiesList(
EIFCSupportSchema scheme,
const TXString& strIfcObjName,
TXStringArray& outArrProperties,
TXStringArray& outArrDefaultValues);

Parameters

scheme EIFCSupportSchema IFC Scheme. Possible values are kIFCSupportScheme_2x2 (IFC 2x2); kIFCSupportScheme_2x3 (IFC 2x3) and kIFCSupportScheme_2x4 (IFC 4).
strIfcObjName TXString IFC entity name.
outArrProperties TXStringArray Returns list of entity members.
outArrDefaultValues TXStringArray Returns list of default values for entity members. Currently returning empty list.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.