VCOM:VectorWorks:Filing:IImportExportSketchup

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Provides import and export functionality for Sketchup file format.

Note This interface is not finished and must not be used!

Interface

// ----------------------------------------------------------------------------------------------------
// {58F756CD-903E-4d9e-9C92-3C844BEAEE7E}
static const VWIID IID_IImportExportSketchup = { 0x58f756cd, 0x903e, 0x4d9e, { 0x9c, 0x92, 0x3c, 0x84, 0x4b, 0xea, 0xee, 0x7e } };

class IImportExportSketchup : public IVWUnknown
{
public:
  virtual VCOMError VCOM_CALLTYPE Import() = 0;
  virtual VCOMError VCOM_CALLTYPE Import(IFileIdentifier* pFileID) = 0;
  virtual VCOMError VCOM_CALLTYPE Export() = 0;
  virtual VCOMError VCOM_CALLTYPE Export(IFileIdentifier* pFileID) = 0;
};

Members

Import Import a 3DS file.
Export Export a 3DS file.

Remarks

Note This interface is not finished and must not be used!

There is predefined type for smart VCOM pointer VCOMPtr to IImportExportSketchup interface:

typedef VCOMPtr<IImportExportSketchup>  IImportExportSketchupPtr;

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]]