VCOM:VectorWorks:Filing:IFolderIdentifier::SetAttributes: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::Filing</code> Member of [[...)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:58, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFolderIdentifier

Set attributes to this folder:

virtual VCOMError VCOM_CALLTYPE SetAttributes(
const SAttributes& attributes) = 0;

Parameters

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed The function failed. That may be because there is no path set to the instance. Or because it failed obtaining the attributes of the folder.
kVCOMError_FileNotFound This folder does not exist on disk.

Remarks

The attributes are obtained inside the structure: see remarks of IFolderIdentifier::GetAttributes

Note Currently not implemented!

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier

[[VCOM:VectorWorks:Filing:IFolderIdentifier]]