VCOM:VectorWorks:Filing:IFileIdentifier::SetAttributes: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::Filing</code> Member of [[...)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:58, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

Set attributes to this file.

virtual VCOMError VCOM_CALLTYPE SetAttributes(
const SAttributes& attributes) = 0;

Parameters

attributes const SAttributes& The new file attributes.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

attributes are obtained inside the structure: see remarks of IFolderIdentifier::GetAttributes.

Note Currently not implemented!

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]