VCOM:VectorWorks:Filing:IFileIdentifier::DuplicateOnDisk

From Vectorworks Developer
Revision as of 14:58, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

Duplicates this file into another file on the disk. The file must exist in the OS.

virtual VCOMError VCOM_CALLTYPE DuplicateOnDisk(
IFileIdentifier *pDestFileID,
bool bOverwrite) = 0;

Parameters

pDestFileID IFileIdentifier* The new file into which this should be duplicated.
bOverwrite bool true to override if the file already exist; false -- the function will fail if the file exist.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]