VCOM:VectorWorks:Filing:IFileChooserDialog::SetMultiSelect: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::Filing</code> Member of [[...)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:58, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileChooserDialog

Set if the dialog should allow multi-selection of files.

This works only for open dialog.

Use IFileChooserDialog::GetSelectedFileNamesCount(Uint32& outValue) and IFileChooserDialog::GetSelectedFileName(Uint32 fileIndex, IFileIdentifier** ppOutFileID) to obtain the file selection array.

virtual VCOMError VCOM_CALLTYPE SetMultiSelect(
bool bMultiSelect) = 0;

Parameters

bMultiSelect bool true to enable multi selection, false to disable it.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]