VCOM:VectorWorks:Filing:IFileChooserDialog::SetDefaultFile

From Vectorworks Developer
Revision as of 14:58, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileChooserDialog

Set default file to be shown when the dialog opens. The file folder is set as active, and the file name and extension are filled in the dialog.

virtual VCOMError VCOM_CALLTYPE SetDefaultFile(
IFileIdentifier* pFileID) = 0;

Parameters

pFileID VCOM:VectorWorks:Filing:IFileIdentifier|IFileIdentifier]]* The file identifier instance that is to be used.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]