VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::SetToolSortStyle

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

Sets the sort style for the tools (ascending, descending, or manual placement)

virtual VCOMError VCOM_CALLTYPE SetToolSortStyle(
Sint16 inSortStyle) = 0;

Parameters

inSortStyle Sint16 the sort style to use for the tools.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.