Template:SimpleDialog: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "<code lang="pas"> PROCEDURE Example; VAR i : INTEGER; BEGIN i := IntDialog('Enter an integer:', '0'); IF NOT DidCancel THEN BEGIN i := i*3; Message(i); END; END; RUN(Example);...")
 
No edit summary
 
Line 1: Line 1:
==== VectorScript ====
<code lang="pas">
<code lang="pas">
PROCEDURE Example;
PROCEDURE Example;

Latest revision as of 20:08, 17 July 2014

VectorScript

PROCEDURE Example;
VAR
i : INTEGER;
BEGIN
i := IntDialog('Enter an integer:', '0');
IF NOT DidCancel THEN BEGIN
i := i*3;
Message(i);
END;
END;
RUN(Example);

Python

def Example():
	i = vs.IntDialog('Enter an integer:', '0');
	if not vs.DidCancel():
		i = i*3
		vs.Message(i)
Example()