Talk:VS:IFC ExportNoUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "__TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> Exports IFC file, showing Export IFC Projec...")
(No difference)

Revision as of 13:39, 5 January 2023

Description

Exports IFC file, showing Export IFC Project dialog

PROCEDURE IFC_ExportWithUI(
bExpSingleObj :BOOLEAN);
def vs.IFC_ExportWithUI(bExpSingleObj):
    return None

Parameters

bExpSingleObj BOOLEAN Set to False.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_ExportWithUI(FALSE);
END;

RUN(Test);

Python

ok = vs.IFC_ExportWithUI(FALSE)

Version

Availability: from Vectorworks 2014