SDK:Dialog Builder Samples

From Vectorworks Developer
Revision as of 15:39, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Create group control

Group controls can be used instead of what ever other control but they can be resized manually with third handle position on the bottom right corner of the bounding box of the control.

The controls that lie within the group controls should be fitten fully within the bounding of the group control. The relations within each group control should start from the top-left-most control within the boundaries of the group control. This means that the first group control is the top-left-most and all other arrange according to it.

Group control sample layout image

And here is the result dialog. Note the outside label control is fully outside the group controls boundaries, and thus it is related to them. The relation between two group controls describe their relation in the layout. The inner labels are fully within the groups.

Group control sample dialog image

Create tab control

For the tab control you have to use 'TabControl' Dialog Builder Control type to represent the control, and to use 'TabPane' to represent each pane in the control. When creting tab control you have to put tab pane control (or what ever other control) and manually change the control type to "Tab Control" since there is no tool prepared for direct creation.

You put the all 'TabPane' within the boundary of the 'TabControl' object as if the 'TabControl' is the container of panes (actualy that's what it is)

Tab control sample layout image

You can see how the tab pane controls are positioned totally within the boudaries of the tab control. Also the tab panes are conected with their handles. The left tab pane is attached to the right one with it's right hanle, which way tab order (or pane indexes) is described.

Left most pane is the first one, and the next follow the right relation. Note that if you dont relate it, not related it it wont be recognized as pane for this tab control

The dialog produced is like this:

Tab control pane 1 sample dialog image Tab control pane 2 sample dialog image

Create swap control

The swap control is the same as tab control. Only that there is no tool for direct creation of swap controls. You have to put tab control (or what ever control) and manually change the type to swap control or swap pane.

You have to use 'SwapControl' Dialog Builder Control type to represent the control, and to use 'SwapPane' to represent each pane in the control.

You put the all 'TabPane' within the boundary of the 'SwapControl' object as if the 'SwapControl' is the container of swap panes (actualy that's what it is)

Tab control sample layout image

You can see how the swap pane controls are positioned totally within the boudaries of the swap control. Also the swap panes are conected with their handles. The left swap pane is attached to the right one with it's right hanle, which way swap order (or pane indexes) is described.

Left most pane is the first one, and the next follow the right relation. Note that if you dont relate it, not related it it wont be recognized as pane for this swap control

The dialog produced is like this:

Tab control sample dialog image

See Also

SDK:Dialog Builder | SDK:Creating handler class for VectorScript layout dialog | SDK:Creating handler class for manual layout dialog |