Help:Adding General Function Reference

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.Help:Contents|Help ..Help:Contents|General Help ..Help:Adding Article|Adding Article ..Help:Adding Function Reference|Adding Function Reference ..Help:Adding General Function Reference|Adding General Function Reference ..Help:Adding VCOM Function Reference|Adding VCOM Function Reference ..Help:Adding VectorScript Function Reference|Adding VectorScript Function Reference

Naming

The actual type of the reference page (is it VectorScript or VCOM) is determined by the category in which the page exist.

The category is represented in the name before the semi-colon in the name.

For example "VCOM:Something" is a page "Something" in category "VCOM".

IMPORTANT Be careful when naming pages. The name is very important!

See Help:Contents#Page Name

General Function Page

Here is information of how to format general function reference page.

More information on the pages and the tags here Help:Adding Reference.

Here is template for general function reference pages:

__TOC__
<vwDoc>

-----------------------------------------------------------------------------------------------------------
<desc>
... some description ...
</desc>

-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="cpp">
... function definition ...
</funcDef>
</def>

-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
...parameter type...
...parameter name...
...parameter information...
</line>
</lineList>
</params>

-----------------------------------------------------------------------------------------------------------
<return>
</return>

-----------------------------------------------------------------------------------------------------------
<remark>
</remark>

-----------------------------------------------------------------------------------------------------------
<sample>
</sample>

-----------------------------------------------------------------------------------------------------------
<version>
</version>

-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>

</vwDoc>

[[Category:...VS or VCOM...:...|...]]

See Also