Energos: Use Record Formats to define energy analysis data: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVSSpecial|specific=}} Category:VectorScript <div class="rightmenu"> __TOC__ </div> By [mailto:vstanev@nemetschek.net Vladislav Stanev] Re...")
 
No edit summary
 
(32 intermediate revisions by 2 users not shown)
Line 19: Line 19:


== Formats ==
== Formats ==
<b>Note: </b> that all the format names and fields are localized. This means that in localized versions of Vectorworks, they will be in the corresponding language. Note the information of how to read the resource containing the localized strings, or look at the scripts below.
=== Wall ===
Attach a record of this format to define the energy properties of a wall
Format name: '''Energos Wall'''
:.vwstring key: ''''EnergyAnalysis/Strings/FormatDef_W.vwallstrings', 'FormatName' '''
{| class="wikitable"
|-
! Field name !! Unit !! Description !! .vwstring key
|-
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
| Name || Text|| Name of wall  || FieldText_Name
|-
| Area || Number|| Area value in document units || FieldDim_Area
|-
| UValue || Number || U - value in document units || FieldReal_UValue
|-
| Orientation || Integer || Orientation values:
:0 - North
:1 - NorthEast
:2 - East
:3 - SouthEast
:4 - South
:5 - SouthWest
:6 - West
:7 - NorthWest
:8 - Horizontal
|| FieldInt_Orientation
|-
| Inclination || Integer || Orientation inclination degrees:
:0 = 0 - Horizontal
:1 = 15
:2 = 30
:3 = 45
:4 = 60
:5 = 90 - Vertical
:6 = 105
:7 = 120
:8 = 135
:9 = 150
:10 = 165
:11 = 180 - Horizontal
|| FieldInt_OrientInclination
|-
| Reduction Factor Shading || Number || The shading reduction factor indicates how much solar radiation is blocked by shading objects || FieldReal_ReductionFactorShading
|-
| Wall Type|| Integer ||
:0 - Exterior Ambient
:1 - Exterior Ground
:2 - Partition To Neighbour
|| FieldInt_WallType
|}
'''Note:''' strings are localizable via 'FormatDef_Wall.vwstrings' of the EnergyAnalysis.vwr


=== Thermal Bridge ===
=== Thermal Bridge ===
Line 24: Line 82:
Attach a record of this format to define the energy properties of a thermal-bridge
Attach a record of this format to define the energy properties of a thermal-bridge


Format name: '''Energy Analysis Thermal Bridge'''
Format name: '''Energos Thermal Bridge'''
:.vwstring key: ''''EnergyAnalysis/Strings/FormatDef_ThermalBridge.vwstrings', 'FormatName' '''
{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
| Sort Index || Integer || Index used to order the elements
|-
|-
| Name || Text||  
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Area || Number|| Area value in document units
| Name || Text|| Name of thermal bridge || FieldText_Name
|-
|-
| Quantity || Integer ||
| Quantity || Integer || Number of thermal bridges || FieldLong_Quantity
|-
|-
| Location || Integer || Location values:<br/>
| Location || Integer || Location values:
0 - None<br/>
:0 - None
1 - Ambient<br/>
:1 - Ambient
2 - Perimeter<br/>
:2 - Perimeter
3 - Floor/Slab
:3 - Floor/Slab  
|| FieldLong_Location
|-
|-
| Length || Number || thermal bridge length in document units
| Length || Number || thermal bridge length in document units || FieldDim_Length
|-
|-
| PSI || Number ||  
| PSI || Number || Measure of linear thermal heat transmittance usually at a junction in a dwelling || FieldReal_PSI
|}
|}
'''Note:''' strings are localizable via 'FormatDef_ThermalBridge.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_ThermalBridge.vwstrings' of the EnergyAnalysis.vwr


=== Window ===
=== Window ===
Line 57: Line 111:
Attach a record of this format to define the energy properties of a window
Attach a record of this format to define the energy properties of a window


Format name: '''Energy Analysis Window'''
Format name: '''Energos Window'''
:.vwstring key: ''''EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings', 'FormatNameWindow' '''


{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text ||  
| Name || Text || Name of window || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units(This is area of whole window) || FieldDim_Area
|-
|-
| UValue || Number || U - value in document units
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:
0 - North<br/>
:0 - North
1 - NorthEast<br/>
:1 - NorthEast
2 - East<br/>
:2 - East
3 - SouthEast<br/>
:3 - SouthEast
4 - South<br/>
:4 - South
5 - SouthWest<br/>
:5 - SouthWest
6 - West<br/>
:6 - West
7 - NorthWest<br/>
:7 - NorthWest
8 - Horizontal
:8 - Horizontal  
|| FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:
0 = 0 - Horizontal<br/>
:0 = 0 - Horizontal
1 = 15<br/>
:1 = 15
2 = 30<br/>
:2 = 30
3 = 45<br/>
:3 = 45
4 = 60<br/>
:4 = 60
5 = 90 - Vertical<br/>
:5 = 90 - Vertical
6 = 105<br/>
:6 = 105
7 = 120<br/>
:7 = 120
8 = 135<br/>
:8 = 135
9 = 150<br/>
:9 = 150
10 = 165<br/>
:10 = 165
11 = 180 - Horizontal<br/>
:11 = 180 - Horizontal  
|| FieldInt_OrientInclination
|-
|-
| Width || Number || Width in document units
| Width || Number || Width in document units(This is width of whole window) || FieldDim_Width
|-
|-
| Glazing Area || Number || Glazing area in document units
| Glazing Area || Number || Glazing area in document units || FieldDim_GlazingArea
|-
|-
| Glazing Length || Number || Glazing length in document units
| Glazing Length || Number || Glazing length in document units(This is glazing perimeter) || FieldDim_GlazingLength
|-
|-
| Frame Length || Number || Frame length in document units
| Frame Length || Number || Frame length in document units(This is installation length) || FieldDim_FrameLength
|-
|-
| Light Transmission Glazing || Number ||  
| Light Transmission Glazing || Number || This is visible transmittance. Transmittance refers to the percentage of radiation that can pass through glazing.Transmission of visible light determines the effectiveness of a type of glass in providing daylight and a clear view through the window. || FieldReal_LightTrasmGlazing
|-
|-
| General Shading || Number || Shading values:<br/>
| General Shading || Number || Shading values:
0 - None<br/>
:0 - None
-1 - Low<br/>
:-1 - Low
-2 - Medium<br/>
:-2 - Medium
-3 - High<br/>
:-3 - High
X - Custom Value as Specified<br/>
:X - Custom Value as Specified
|| FieldReal_ShadingGeneral
|-
|-
| Surrounding Shading || Number || Same values as general shading
| Surrounding Shading || Number || Same values as general shading || FieldReal_ShadingSurrounding
|-
|-
| Summer Shading || Number || Same values as general shading
| Summer Shading || Number || Same values as general shading || FieldReal_ShadingSummer
|-
|-
| Additional Shading || Number || Same values as general shading
| Additional Shading || Number || Same values as general shading || FieldReal_ShadingAdditional
|}
|}
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr


=== Door ===
=== Door ===
Line 129: Line 183:
Attach a record of this format to define the energy properties of a door
Attach a record of this format to define the energy properties of a door


Format name: '''Energy Analysis Door'''
Format name: '''Energos Door'''
:.vwstring key: ''''EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings', 'FormatNameDoor' '''


{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text ||  
| Name || Text || Name of door || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units(This is area of whole door) || FieldDim_Area
|-
|-
| UValue || Number || U - value in document units
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:
0 - North<br/>
:0 - North
1 - NorthEast<br/>
:1 - NorthEast
2 - East<br/>
:2 - East
3 - SouthEast<br/>
:3 - SouthEast
4 - South<br/>
:4 - South
5 - SouthWest<br/>
:5 - SouthWest
6 - West<br/>
:6 - West
7 - NorthWest<br/>
:7 - NorthWest
8 - Horizontal<br/>
:8 - Horizontal
|| FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:
0 = 0 - Horizontal<br/>
:0 = 0 - Horizontal
1 = 15<br/>
:1 = 15
2 = 30<br/>
:2 = 30
3 = 45<br/>
:3 = 45
4 = 60<br/>
:4 = 60
5 = 90 - Vertical<br/>
:5 = 90 - Vertical
6 = 105<br/>
:6 = 105
7 = 120<br/>
:7 = 120
8 = 135<br/>
:8 = 135
9 = 150<br/>
:9 = 150
10 = 165<br/>
:10 = 165
11 = 180 - Horizontal<br/>
:11 = 180 - Horizontal
|| FieldInt_OrientInclination
|-
|-
| Width || Number || Width in document units
| Width || Number || Width in document units(This is width of whole door) || FieldDim_Width
|-
|-
| Glazing Area || Number || Glazing area in document units
| Glazing Area || Number || Glazing area in document units || FieldDim_GlazingArea
|-
|-
| Glazing Length || Number || Glazing length in document units
| Glazing Length || Number || Glazing length in document units(This is glazing perimeter) || FieldDim_GlazingLength
|-
|-
| Frame Length || Number || Frame length in document units
| Frame Length || Number || Frame length in document units(This is installation length) || FieldDim_FrameLength
|-
|-
| Light Transmission Glazing || Number ||
| Light Transmission Glazing || Number || This is visible transmittance. Transmittance refers to the percentage of radiation that can pass through glazing. Transmission of visible light determines the effectiveness of a type of glass in providing daylight and a clear view through the door. || FieldReal_LightTrasmGlazing
|-
|-
| General Shading || Number || Shading values:<br/>
| General Shading || Number || Shading values:
0 - None<br/>
:0 - None
-1 - Low<br/>
:-1 - Low
-2 - Medium<br/>
:-2 - Medium
-3 - High<br/>
:-3 - High
X - Custom Value as Specified<br/>
:X - Custom Value as Specified
|| FieldReal_ShadingGeneral
|-
|-
| Surrounding Shading || Number || Same values as general shading
| Surrounding Shading || Number || Same values as general shading || FieldReal_ShadingSurrounding
|-
|-
| Summer Shading || Number || Same values as general shading
| Summer Shading || Number || Same values as general shading || FieldReal_ShadingSummer
|-
|-
| Additional Shading || Number || Same values as general shading
| Additional Shading || Number || Same values as general shading || FieldReal_ShadingAdditional
|}
|}
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr


=== Space ===
=== Space ===
Line 201: Line 255:
Attach a record of this format to define the energy properties of a space
Attach a record of this format to define the energy properties of a space


Format name: '''Energy Analysis Space'''
Format name: '''Energos Space'''
:.vwstring key: ''''EnergyAnalysis/Strings/FormatDef_Space.vwstrings', 'FormatName' '''


{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Name || Text ||  
| Name || Text || Name of space || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| Volume || Number || Volume value in document units
| Volume || Number || Volume value in document units || FieldDim_Volume
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:
0 - North<br/>
:0 - North
1 - NorthEast<br/>
:1 - NorthEast
2 - East<br/>
:2 - East
3 - SouthEast<br/>
:3 - SouthEast
4 - South<br/>
:4 - South
5 - SouthWest<br/>
:5 - SouthWest
6 - West<br/>
:6 - West
7 - NorthWest<br/>
:7 - NorthWest
8 - Horizontal<br/>
:8 - Horizontal  
|| FieldInt_Orientation
|-
|-
| Width || Number || Width in document units
| Width || Number || Width in document units(This is length of wall with windows. If there are more than one wall with windows, we chose the wall which the sum of glazing area is biggest.) || FieldDim_Width
|-
|-
| Depth || Number || Depth in document units
| Depth || Number || Depth in document units(This is length from the wall with windows till end of the space. If there are more than one wall with windows, we chose the wall which the sum of glazing area is biggest.) || FieldDim_Depth
|-
|-
| Height || Number || Height in document units
| Height || Number || Height in document units(This is average height of room) || FieldDim_Height
|-
|-
| Lintel Height || Number || Height in document units
| Lintel Height || Number || Height in document units(This is the highest part of the room) || FieldDim_LintelHeight
|-
|-
| Window Width || Number || Width in document units
| Window Width || Number || Width in document units(This is the sum of all windows' width) || FieldDim_WindowWidth
|-
|-
| Light Transmission Glazing Percent || Number || ||
| Light Transmission Glazing Percent || Number || This is visible transmittance. Transmittance refers to the percentage of radiation that can pass through glazing. Transmission of visible light determines the effectiveness of a type of glass in providing daylight and a clear view through the biggest window. || FieldReal_LightTransmissionGlazingPercent
|-
|-
| Lighting Full Load Hours || Number || h/a
| Lighting Full Load Hours || Number || h/a Full load hours for lighting || FieldReal_LightingFullLoadHours
|-
|-
| Installer Light Power || Number || Document unit for W/m2
| Installer Light Power || Number || Document unit for W/m2(This is installed lighting power) || FieldReal_InstalledLightPower
|-
|-
| Lighting Control || Integer || Lighting Control Values:<br/>
| Lighting Control || Integer || Lighting Control Values:
0 - Manual<br/>
:0 - Manual
1 - WithoutOffMode<br/>
:1 - WithoutOffMode
2 - WithOffMode<br/>
:2 - WithOffMode
3 - BusSystem<br/>
:3 - BusSystem
|| FieldInt_LightingControl
|-
|-
| Motion Detector || Boolean ||  
| Motion Detector || Boolean || True, if it is with motion detector. || FieldBool_MotionDetector
|-
|-
| Extract Air Room Type || Integer || Extract Air Room Type Value:<br/>
| Extract Air Room Type || Integer || Extract Air Room Type Value:
0 - Kitchen<br/>
:0 - Kitchen
1 - Bathroom<br/>
:1 - Bathroom
2 - Shower<br/>
:2 - Shower
3 - WC<br/>
:3 - WC
4 - Other<br/>
:4 - Other
|| FieldInt_ExtractAirRoomType
|-
|-
| Extract Air Requirement Volume || Number || Document volume/h
| Extract Air Requirement Volume || Number || Document volume/h(Extract air requirement for the room) || FieldDim_ExtractAirRequirement
|}
|}
'''Note:''' strings are localizable via 'FormatDef_Space.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_Space.vwstrings' of the EnergyAnalysis.vwr


=== Slab ===
=== Slab ===
Line 268: Line 321:
Attach a record of this format to define the energy properties of a slab
Attach a record of this format to define the energy properties of a slab


Format name: '''Energy Analysis Slab'''
Format name: '''Energos Slab'''
:.vwstring key: ''''EnergyAnalysis/Strings/FormatDef_Slab.vwstrings', 'FormatName' '''


{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
|-
| Sort Index || Integer || Index used to order the elements
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Name || Text ||
| Name || Text || Name of slab || FieldText_Name
|-
|-
| Area || Number || Area value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| UValue || Number || U - value in document units
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || Orientation values:<br/>
| Orientation || Integer || Orientation values:
0 - North<br/>
:0 - North
1 - NorthEast<br/>
:1 - NorthEast
2 - East<br/>
:2 - East
3 - SouthEast<br/>
:3 - SouthEast
4 - South<br/>
:4 - South
5 - SouthWest<br/>
:5 - SouthWest
6 - West<br/>
:6 - West
7 - NorthWest<br/>
:7 - NorthWest
8 - Horizontal<br/>
:8 - Horizontal
|| FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:
0 = 0 - Horizontal<br/>
:0 = 0 - Horizontal
1 = 15<br/>
:1 = 15
2 = 30<br/>
:2 = 30
3 = 45<br/>
:3 = 45
4 = 60<br/>
:4 = 60
5 = 90 - Vertical<br/>
:5 = 90 - Vertical
6 = 105<br/>
:6 = 105
7 = 120<br/>
:7 = 120
8 = 135<br/>
:8 = 135
9 = 150<br/>
:9 = 150
10 = 165<br/>
:10 = 165
11 = 180 - Horizontal<br/>
:11 = 180 - Horizontal
|| FieldInt_OrientInclination
|-
|-
| RS Internal || Number ||
| RS Internal || Number || Interior heat transfer resistance || FieldReal_RSInternal
|-
|-
| RS External || Number ||
| RS External || Number || Exterior heat transfer resistance || FieldReal_RSExternal
|-
|-
| Exposed Perimeter To Open || Number ||
| Exposed Perimeter To Open || Number || This is the sum of edges which are exposed to the open. || FieldReal_ExposedPerimToOpen
|}
|}
Note: strings are localizable via 'FormatDef_Slab.vwstrings' of the EnergyAnalysis.vwr
Note: strings are localizable via 'FormatDef_Slab.vwstrings' of the EnergyAnalysis.vwr
Wall -- Attach a record of this format to define the energy properties of a wall
Format name: Energy Analysis Wall
{| class="wikitable"
|-
| Field name || Unit || Description
|-
| Sort Index || Integer || Index used to order the elements
|-
| Name || Text ||
|-
| Area || Number || Area value in document units
|-
| UValue || Number || U - value in document units
|-
| Orientation || Integer || Orientation values:<br/>
0 - North<br/>
1 - NorthEast<br/>
2 - East<br/>
3 - SouthEast<br/>
4 - South<br/>
5 - SouthWest<br/>
6 - West<br/>
7 - NorthWest<br/>
8 - Horizontal<br/>
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
0 = 0 - Horizontal<br/>
1 = 15<br/>
2 = 30<br/>
3 = 45<br/>
4 = 60<br/>
5 = 90 - Vertical<br/>
6 = 105<br/>
7 = 120<br/>
8 = 135<br/>
9 = 150<br/>
10 = 165<br/>
11 = 180 - Horizontal<br/>
|-
| Reduction Factor Shading || Number ||
|-
| Wall Type || Integer || Wall types:<br/>
0 = Exterior Ambient<br/>
1 = Exterior Ground<br/>
2 = Partition to Neighbour<br/>
|}
'''Note:''' strings are localizable via 'FormatDef_Wall.vwstrings' of the EnergyAnalysis.vwr


=== Roof ===
=== Roof ===
Line 375: Line 375:
Attach a record of this format to define the energy properties of a roof
Attach a record of this format to define the energy properties of a roof


Format name: '''Energy Analysis Roof'''
Format name: '''Energos Roof'''
:.vwstring key: ''''EnergyAnalysis/Strings/FormatDef_Roof.vwstrings', 'FormatName' '''


{| class="wikitable"
{| class="wikitable"
|-
|-
! Field name !! Unit !! Description
! Field name !! Unit !! Description !! .vwstring key
|-
| Sort Index || Integer || Index used to order the elements
|-
|-
| Name || Text ||  
| Sort Index || Integer || Index used to order the elements || FieldInt_SortIndex
|-
|-
| Area || Number || Area value in document units
| Name || Text || Name of roof || FieldText_Name
|-
|-
| UValue || Number || U - value in document units
| Area || Number || Area value in document units || FieldDim_Area
|-
|-
| Orientation || Integer ||
| UValue || Number || U - value in document units || FieldReal_UValue
|-
|-
| Orientation || Integer || values:<br/>
| Orientation || Integer || values:
0 - North<br/>
:0 - North
1 - NorthEast<br/>
:1 - NorthEast
2 - East<br/>
:2 - East
3 - SouthEast<br/>
:3 - SouthEast
4 - South<br/>
:4 - South
5 - SouthWest<br/>
:5 - SouthWest
6 - West<br/>
:6 - West
7 - NorthWest<br/>
:7 - NorthWest
8 - Horizontal<br/>
:8 - Horizontal
|| FieldInt_Orientation
|-
|-
| Inclination || Integer || Orientation inclination degrees:<br/>
| Inclination || Integer || Orientation inclination degrees:
0 = 0 - Horizontal<br/>
:0 = 0 - Horizontal
1 = 15<br/>
:1 = 15
2 = 30<br/>
:2 = 30
3 = 45<br/>
:3 = 45
4 = 60<br/>
:4 = 60
5 = 90 - Vertical<br/>
:5 = 90 - Vertical
6 = 105<br/>
:6 = 105
7 = 120<br/>
:7 = 120
8 = 135<br/>
:8 = 135
9 = 150<br/>
:9 = 150
10 = 165<br/>
:10 = 165
11 = 180 - Horizontal
:11 = 180 - Horizontal  
|| FieldInt_OrientInclination
|-
|-
| Reduction Factor Shading || Number ||  
| Reduction Factor Shading || Number || The shading reduction factor indicates how much solar radiation is blocked by shading objects. || FieldReal_ReductionFactorShading
|}
|}


'''Note:''' strings are localizable via 'FormatDef_Roof.vwstrings' of the EnergyAnalysis.vwr
'''Note:''' strings are localizable via 'FormatDef_Roof.vwstrings' of the EnergyAnalysis.vwr


== Example Scripts - Python Script==
== Example Scipts ==


You can use the following scripts to create the formats:
You can use the following scripts to create the formats:


=== Wall ===
<code lang="py">
# Energos Wall
vwr = 'EnergyAnalysis/Strings/FormatDef_Wall.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_SortIndex"              ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldText_Name"                  ), '', 4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldDim_Area"                  ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldReal_UValue"                ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_Orientation"            ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_OrientInclination"      ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldReal_ReductionFactorShading"), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_WallType"              ), '0', 1, 0 ) #int
</code>
=== Thermal Bridge ===
=== Thermal Bridge ===


<code lang="vs">
<code lang="py">
{Energy Analysis Thermal Bridge}
# Energos Thermal Bridge
NewField('Energy Analysis Thermal Bridge','Sort Index', '0', 1{int}, 0 );
vwr = 'EnergyAnalysis/Strings/FormatDef_ThermalBridge.vwstrings'
NewField('Energy Analysis Thermal Bridge','Name', '', 4{text}, 0 );
formatName = vs.GetVWRString(vwr, 'FormatName' )
NewField('Energy Analysis Thermal Bridge','Quantity', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'), '0', 1, 0 ) #int
NewField('Energy Analysis Thermal Bridge','Location', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'   ), '', 4, 0 ) #text
NewField('Energy Analysis Thermal Bridge','Length', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldLong_Quantity'), '0', 1, 0 ) #int
NewField('Energy Analysis Thermal Bridge','PSI', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldLong_Location'), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Length'   ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_PSI'     ), '0', 3, 0 ) #real
</code>
</code>
   
   
Line 442: Line 457:
=== Window ===  
=== Window ===  
   
   
<code lang="vs">
<code lang="py">
{Energy Analysis Window}
# Energos Window
NewField('Energy Analysis Window', 'Sort Index', '0', 1{int}, 0 );
vwr = 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings'
NewField('Energy Analysis Window', 'Name', '',  4{text}, 0 );
formatName = vs.GetVWRString(vwr, 'FormatNameWindow' )
NewField('Energy Analysis Window', 'Area', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'         ), '0', 1, 0 ) #int
NewField('Energy Analysis Window', 'UValue', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'             ), '',  4, 0 ) #text
NewField('Energy Analysis Window', 'Orientation', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'Inclination', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'           ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'Width', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'       ), '0', 1, 0 ) #int
NewField('Energy Analysis Window', 'Glazing Area', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination' ), '0', 1, 0 ) #int
NewField('Energy Analysis Window', 'Glazing Length', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'             ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'Frame Length', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingArea'       ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'Light Transmission Glazing','0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingLength'     ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'General Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_FrameLength'       ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'Surrounding Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTrasmGlazing' ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'Summer Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingGeneral'   ), '0', 3, 0 ) #real
NewField('Energy Analysis Window', 'Additional Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSurrounding'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSummer'     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingAdditional' ), '0', 3, 0 ) #real
</code>
</code>
   
   
Line 464: Line 481:
=== Door ===
=== Door ===


<code lang="vs">
<code lang="py">
{Energy Analysis Door}
# Energos Door
NewField('Energy Analysis Door', 'Sort Index', '0', 1{int}, 0 );
vwr = 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings'
NewField('Energy Analysis Door', 'Name', '',  4{text}, 0 );
formatName = vs.GetVWRString(vwr, 'FormatNameDoor' )
NewField('Energy Analysis Door', 'Area', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'         ), '0', 1, 0 ) #int
NewField('Energy Analysis Door', 'UValue', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'             ), '',  4, 0 ) #text
NewField('Energy Analysis Door', 'Orientation', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'Inclination', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'           ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'Width', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'       ), '0', 1, 0 ) #int
NewField('Energy Analysis Door', 'Glazing Area', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination' ), '0', 1, 0 ) #int
NewField('Energy Analysis Door', 'Glazing Length', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'             ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'Frame Length', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingArea'       ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'Light Transmission Glazing', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingLength'     ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'General Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_FrameLength'       ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'Surrounding Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTrasmGlazing' ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'Summer Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingGeneral'   ), '0', 3, 0 ) #real
NewField('Energy Analysis Door', 'Additional Shading', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSurrounding'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSummer'     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingAdditional' ), '0', 3, 0 ) #real
</code>
</code>
   
   
Line 486: Line 505:
=== Space ===
=== Space ===


<code lang="vs">
<code lang="py">
{Energy Analysis Space}
# Energos Space
NewField('Energy Analysis Space', 'Name', '',  4{text}, 0 );
vwr = 'EnergyAnalysis/Strings/FormatDef_Space.vwstrings'
NewField('Energy Analysis Space', 'Area', '0', 3{real}, 0 );
formatName = vs.GetVWRString(vwr, 'FormatName' )
NewField('Energy Analysis Space', 'Volume', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'                           ), '',  4, 0 ) #text
NewField('Energy Analysis Space', 'Orientation', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'                           ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Width', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Volume'                         ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Depth', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'                     ), '0', 1, 0 ) #int
NewField('Energy Analysis Space', 'Height', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'                           ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Lintel Height', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Depth'                           ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Window Width', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Height'                         ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Light Transmission Glazing Percent', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_LintelHeight'                   ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Lighting Full Load Hours', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_WindowWidth'                     ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Installer Light Power', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTransmissionGlazingPercent'), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Lighting Control', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightingFullLoadHours'         ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Motion Detector', '0', 2{bool}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_InstalledLightPower'           ), '0', 3, 0 ) #real
NewField('Energy Analysis Space', 'Extract Air Room Type', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_LightingControl'                 ), '0', 1, 0 ) #int
NewField('Energy Analysis Space', 'Extract Air Requirement Volume', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldBool_MotionDetector'                 ), '0', 2, 0 ) #bool
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_ExtractAirRoomType'             ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_ExtractAirRequirement'           ), '0', 3, 0 ) #real
</code>
</code>


=== Slab ===
=== Slab ===


<code lang="vs">
<code lang="py">
{Energy Analysis Slab}
# Energos Slab
NewField('Energy Analysis Slab', 'Sort Index', '0', 1{int}, 0 );
vwr = 'EnergyAnalysis/Strings/FormatDef_Slab.vwstrings'
NewField('Energy Analysis Slab', 'Name', '',  4{text}, 0 );
formatName = vs.GetVWRString(vwr, 'FormatName' )
NewField('Energy Analysis Slab', 'Area', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'         ), '0', 1, 0 ) #real
NewField('Energy Analysis Slab', 'UValue', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'             ), '',  4, 0 ) #text
NewField('Energy Analysis Slab', 'Orientation', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
NewField('Energy Analysis Slab', 'Inclination', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'           ), '0', 3, 0 ) #real
NewField('Energy Analysis Slab', 'RS Internal', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'       ), '0', 1, 0 ) #int
NewField('Energy Analysis Slab', 'RS External', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination' ), '0', 1, 0 ) #int
NewField('Energy Analysis Slab', 'Exposed Perimeter To Open', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_RSInternal'       ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_RSExternal'       ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ExposedPerimToOpen'), '0', 3, 0 ) #real
</code>
</code>
   
   
Line 525: Line 547:
=== Roof ===
=== Roof ===


<code lang="vs">
<code lang="py">
{Energy Analysis Roof}
# Energos Roof
NewField('Energy Analysis Roof', 'Sort Index', '0', 1{int}, 0 );
vwr = 'EnergyAnalysis/Strings/FormatDef_Roof.vwstrings'
NewField('Energy Analysis Roof', 'Nam', '',  4{text}, 0 );
formatName = vs.GetVWRString(vwr, 'FormatName' )
NewField('Energy Analysis Roof', 'Area', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'             ), '0', 1, 0 ) #int
NewField('Energy Analysis Roof', 'UValue', '0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'                 ), '',  4, 0 ) #text
NewField('Energy Analysis Roof', 'Orientation', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'                   ), '0', 3, 0 ) #real
NewField('Energy Analysis Roof', 'Inclination', '0', 1{int}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'               ), '0', 3, 0 ) #real
NewField('Energy Analysis Roof', 'Reduction Factor Shading','0', 3{real}, 0 );
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'           ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'     ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ReductionFactorShading'), '0', 3, 0 ) #real
</code>
</code>

Latest revision as of 07:51, 18 June 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

By Vladislav Stanev

Records can be attached to any object to define energy analysis data to be used. Depending on the record the object is identified and used as the corresponding energy analysis element.

Note that these records/formats don't define the full set of properties. They are designed for simplicity to allow any Vectorworks object to be setup to participate in the energy analysis.

if you are integrating custom parametric objects with the energy analysis feature see:

Here is the definition of the formats that are recognized by the feature (all noted units are units defined by the energy analysis units settings):

Formats

Note: that all the format names and fields are localized. This means that in localized versions of Vectorworks, they will be in the corresponding language. Note the information of how to read the resource containing the localized strings, or look at the scripts below.

Wall

Attach a record of this format to define the energy properties of a wall

Format name: Energos Wall

.vwstring key: 'EnergyAnalysis/Strings/FormatDef_W.vwallstrings', 'FormatName'
Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text Name of wall FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:
0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
FieldInt_Orientation
Inclination Integer Orientation inclination degrees:
0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
FieldInt_OrientInclination
Reduction Factor Shading Number The shading reduction factor indicates how much solar radiation is blocked by shading objects FieldReal_ReductionFactorShading
Wall Type Integer
0 - Exterior Ambient
1 - Exterior Ground
2 - Partition To Neighbour
FieldInt_WallType

Note: strings are localizable via 'FormatDef_Wall.vwstrings' of the EnergyAnalysis.vwr

Thermal Bridge

Attach a record of this format to define the energy properties of a thermal-bridge

Format name: Energos Thermal Bridge

.vwstring key: 'EnergyAnalysis/Strings/FormatDef_ThermalBridge.vwstrings', 'FormatName'
Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text Name of thermal bridge FieldText_Name
Quantity Integer Number of thermal bridges FieldLong_Quantity
Location Integer Location values:
0 - None
1 - Ambient
2 - Perimeter
3 - Floor/Slab
FieldLong_Location
Length Number thermal bridge length in document units FieldDim_Length
PSI Number Measure of linear thermal heat transmittance usually at a junction in a dwelling FieldReal_PSI

Note: strings are localizable via 'FormatDef_ThermalBridge.vwstrings' of the EnergyAnalysis.vwr

Window

Attach a record of this format to define the energy properties of a window

Format name: Energos Window

.vwstring key: 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings', 'FormatNameWindow'
Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text Name of window FieldText_Name
Area Number Area value in document units(This is area of whole window) FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:
0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
FieldInt_Orientation
Inclination Integer Orientation inclination degrees:
0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
FieldInt_OrientInclination
Width Number Width in document units(This is width of whole window) FieldDim_Width
Glazing Area Number Glazing area in document units FieldDim_GlazingArea
Glazing Length Number Glazing length in document units(This is glazing perimeter) FieldDim_GlazingLength
Frame Length Number Frame length in document units(This is installation length) FieldDim_FrameLength
Light Transmission Glazing Number This is visible transmittance. Transmittance refers to the percentage of radiation that can pass through glazing.Transmission of visible light determines the effectiveness of a type of glass in providing daylight and a clear view through the window. FieldReal_LightTrasmGlazing
General Shading Number Shading values:
0 - None
-1 - Low
-2 - Medium
-3 - High
X - Custom Value as Specified
FieldReal_ShadingGeneral
Surrounding Shading Number Same values as general shading FieldReal_ShadingSurrounding
Summer Shading Number Same values as general shading FieldReal_ShadingSummer
Additional Shading Number Same values as general shading FieldReal_ShadingAdditional

Note: strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr

Door

Attach a record of this format to define the energy properties of a door

Format name: Energos Door

.vwstring key: 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings', 'FormatNameDoor'
Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text Name of door FieldText_Name
Area Number Area value in document units(This is area of whole door) FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:
0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
FieldInt_Orientation
Inclination Integer Orientation inclination degrees:
0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
FieldInt_OrientInclination
Width Number Width in document units(This is width of whole door) FieldDim_Width
Glazing Area Number Glazing area in document units FieldDim_GlazingArea
Glazing Length Number Glazing length in document units(This is glazing perimeter) FieldDim_GlazingLength
Frame Length Number Frame length in document units(This is installation length) FieldDim_FrameLength
Light Transmission Glazing Number This is visible transmittance. Transmittance refers to the percentage of radiation that can pass through glazing. Transmission of visible light determines the effectiveness of a type of glass in providing daylight and a clear view through the door. FieldReal_LightTrasmGlazing
General Shading Number Shading values:
0 - None
-1 - Low
-2 - Medium
-3 - High
X - Custom Value as Specified
FieldReal_ShadingGeneral
Surrounding Shading Number Same values as general shading FieldReal_ShadingSurrounding
Summer Shading Number Same values as general shading FieldReal_ShadingSummer
Additional Shading Number Same values as general shading FieldReal_ShadingAdditional

Note: strings are localizable via 'FormatDef_WinDoor.vwstrings' of the EnergyAnalysis.vwr

Space

Attach a record of this format to define the energy properties of a space

Format name: Energos Space

.vwstring key: 'EnergyAnalysis/Strings/FormatDef_Space.vwstrings', 'FormatName'
Field name Unit Description .vwstring key
Name Text Name of space FieldText_Name
Area Number Area value in document units FieldDim_Area
Volume Number Volume value in document units FieldDim_Volume
Orientation Integer Orientation values:
0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
FieldInt_Orientation
Width Number Width in document units(This is length of wall with windows. If there are more than one wall with windows, we chose the wall which the sum of glazing area is biggest.) FieldDim_Width
Depth Number Depth in document units(This is length from the wall with windows till end of the space. If there are more than one wall with windows, we chose the wall which the sum of glazing area is biggest.) FieldDim_Depth
Height Number Height in document units(This is average height of room) FieldDim_Height
Lintel Height Number Height in document units(This is the highest part of the room) FieldDim_LintelHeight
Window Width Number Width in document units(This is the sum of all windows' width) FieldDim_WindowWidth
Light Transmission Glazing Percent Number This is visible transmittance. Transmittance refers to the percentage of radiation that can pass through glazing. Transmission of visible light determines the effectiveness of a type of glass in providing daylight and a clear view through the biggest window. FieldReal_LightTransmissionGlazingPercent
Lighting Full Load Hours Number h/a Full load hours for lighting FieldReal_LightingFullLoadHours
Installer Light Power Number Document unit for W/m2(This is installed lighting power) FieldReal_InstalledLightPower
Lighting Control Integer Lighting Control Values:
0 - Manual
1 - WithoutOffMode
2 - WithOffMode
3 - BusSystem
FieldInt_LightingControl
Motion Detector Boolean True, if it is with motion detector. FieldBool_MotionDetector
Extract Air Room Type Integer Extract Air Room Type Value:
0 - Kitchen
1 - Bathroom
2 - Shower
3 - WC
4 - Other
FieldInt_ExtractAirRoomType
Extract Air Requirement Volume Number Document volume/h(Extract air requirement for the room) FieldDim_ExtractAirRequirement

Note: strings are localizable via 'FormatDef_Space.vwstrings' of the EnergyAnalysis.vwr

Slab

Attach a record of this format to define the energy properties of a slab

Format name: Energos Slab

.vwstring key: 'EnergyAnalysis/Strings/FormatDef_Slab.vwstrings', 'FormatName'
Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text Name of slab FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer Orientation values:
0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
FieldInt_Orientation
Inclination Integer Orientation inclination degrees:
0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
FieldInt_OrientInclination
RS Internal Number Interior heat transfer resistance FieldReal_RSInternal
RS External Number Exterior heat transfer resistance FieldReal_RSExternal
Exposed Perimeter To Open Number This is the sum of edges which are exposed to the open. FieldReal_ExposedPerimToOpen

Note: strings are localizable via 'FormatDef_Slab.vwstrings' of the EnergyAnalysis.vwr

Roof

Attach a record of this format to define the energy properties of a roof

Format name: Energos Roof

.vwstring key: 'EnergyAnalysis/Strings/FormatDef_Roof.vwstrings', 'FormatName'
Field name Unit Description .vwstring key
Sort Index Integer Index used to order the elements FieldInt_SortIndex
Name Text Name of roof FieldText_Name
Area Number Area value in document units FieldDim_Area
UValue Number U - value in document units FieldReal_UValue
Orientation Integer values:
0 - North
1 - NorthEast
2 - East
3 - SouthEast
4 - South
5 - SouthWest
6 - West
7 - NorthWest
8 - Horizontal
FieldInt_Orientation
Inclination Integer Orientation inclination degrees:
0 = 0 - Horizontal
1 = 15
2 = 30
3 = 45
4 = 60
5 = 90 - Vertical
6 = 105
7 = 120
8 = 135
9 = 150
10 = 165
11 = 180 - Horizontal
FieldInt_OrientInclination
Reduction Factor Shading Number The shading reduction factor indicates how much solar radiation is blocked by shading objects. FieldReal_ReductionFactorShading

Note: strings are localizable via 'FormatDef_Roof.vwstrings' of the EnergyAnalysis.vwr

Example Scripts - Python Script

You can use the following scripts to create the formats:

Wall

# Energos Wall
vwr = 'EnergyAnalysis/Strings/FormatDef_Wall.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_SortIndex"              ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldText_Name"                  ), '', 4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldDim_Area"                   ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldReal_UValue"                ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_Orientation"            ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_OrientInclination"      ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldReal_ReductionFactorShading"), '0', 3, 0 ) #real	
vs.NewField(formatName, vs.GetVWRString(vwr, "FieldInt_WallType"               ), '0', 1, 0 ) #int

Thermal Bridge

# Energos Thermal Bridge
vwr = 'EnergyAnalysis/Strings/FormatDef_ThermalBridge.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'    ), '', 4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldLong_Quantity'), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldLong_Location'), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Length'   ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_PSI'     ), '0', 3, 0 ) #real


Window

# Energos Window
vwr = 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatNameWindow' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'          ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'              ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'        ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'  ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'              ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingArea'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingLength'      ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_FrameLength'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTrasmGlazing' ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingGeneral'    ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSurrounding'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSummer'     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingAdditional' ), '0', 3, 0 ) #real


Door

# Energos Door
vwr = 'EnergyAnalysis/Strings/FormatDef_WinDoor.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatNameDoor' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'          ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'              ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'        ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'  ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'              ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingArea'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_GlazingLength'      ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_FrameLength'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTrasmGlazing' ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingGeneral'    ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSurrounding'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingSummer'     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ShadingAdditional' ), '0', 3, 0 ) #real


Space

# Energos Space
vwr = 'EnergyAnalysis/Strings/FormatDef_Space.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'                           ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'                            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Volume'                          ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'                     ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Width'                           ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Depth'                           ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Height'                          ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_LintelHeight'                    ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_WindowWidth'                     ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightTransmissionGlazingPercent'), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_LightingFullLoadHours'          ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_InstalledLightPower'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_LightingControl'                 ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldBool_MotionDetector'                 ), '0', 2, 0 ) #bool
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_ExtractAirRoomType'              ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_ExtractAirRequirement'           ), '0', 3, 0 ) #real

Slab

# Energos Slab
vwr = 'EnergyAnalysis/Strings/FormatDef_Slab.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'          ), '0', 1, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'              ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'               ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'            ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'        ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'  ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_RSInternal'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_RSExternal'        ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ExposedPerimToOpen'), '0', 3, 0 ) #real


Roof

# Energos Roof
vwr = 'EnergyAnalysis/Strings/FormatDef_Roof.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_SortIndex'              ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldText_Name'                  ), '',  4, 0 ) #text
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldDim_Area'                   ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_UValue'                ), '0', 3, 0 ) #real
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_Orientation'            ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldInt_OrientInclination'      ), '0', 1, 0 ) #int
vs.NewField(formatName, vs.GetVWRString(vwr, 'FieldReal_ReductionFactorShading'), '0', 3, 0 ) #real