VCOM:VectorWorks:Filing:IImportExportDWG::Import

From Vectorworks Developer
Revision as of 14:58, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IImportExportDWG

Import as DWG/DXF file using default settings.

virtual VCOMErrorVCOM_CALLTYPE Import( ) = 0;
virtual VCOMErrorVCOM_CALLTYPE Import(
IFileIdentifier* pFileID,
const bool isSilentDWGImport) = 0;

Parameters

pFileID IFileIdentifier* File that is to be imported.
isSilentDWGImport const bool True if the import should not bring any dialogs.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]]