VCOM:VectorWorks:Filing:IXMLFileNode::FindChildNode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::Filing</code> Member of [[...)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:58, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IXMLFileNode

This function is the same as the non indexed variant ofIXMLFileNode::GetChildNode.

virtual VCOMError VCOM_CALLTYPE FindChildNode(
const TXString& nodeName,
IXMLFileNode** ppOutNode) = 0;

Parameters

nodeName const TXString& The node name.
ppOutNode IXMLFileNode** Output parameter. The result node instance.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFileNode | VCOM:VectorWorks:Filing:IXMLFile

VCOM:VectorWorks:Filing:IXMLFileNode::GetChildNode

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFileNode]] | [[VCOM:VectorWorks:Filing:IXMLFile]] [[VCOM:VectorWorks:Filing:IXMLFileNode::GetChildNode]]