VCOM:VectorWorks:Workspaces:IWorkspaceFile::CreateTool: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::Workspaces</code> Member o...)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Creates a tool in the workspace if it does not exist.

virtual VCOMError VCOM_CALLTYPE CreateTool(
const TXString& inIdentifier,
IWorkspaceTool** outTool) = 0;

Parameters

inIdentifier const TXString& the identifier to be used to represent this tool. Use the IWorkspaces interface to create this identifier.
outTool IWorkspaceTool** will be the newly created tool in the workspace.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.