VCOM:VectorWorks:ISDK::GetComponentPenWeights: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(No difference)

Latest revision as of 15:00, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the pen weights of the left and right sides of a component in an object.

virtual Boolean VCOM_CALLTYPE GetComponentPenWeights(
MCObjectHandle object,
short componentIndex,
Uint8& leftPenWeight,
Uint8& rightPenWeight) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
leftPenWeight Uint8& Returns the pen weight of the component's left line.
rightPenWeight Uint8& Returns the pen weight of the component's right line.

Version

Availability: from Vectorworks 2009