VS:vsoStateClear

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Clears states between events. Must be called during the regen event 3 (kParametricRecalculate).

See VS:Parametric_State_Notifications#Reset_event

PROCEDURE vsoStateClear(
hObj  : HANDLE);
def vs.vsoStateClear(hObj):
    return None

Parameters

hObj HANDLE

Remarks

{ Orso quoting Vlado: In order to receive correct information on received states in between resets, IT IS EXTREMELY IMPORTANT to call VS:vsoStateClear at the end of the reset event }

Example

  3: {kParametricRecalculate}
  BEGIN
    { ... }
    vsoStateClear( objectHand );
  END;

Version

Availability: from All Versions

This is drop-in function.