VS:vsoPrmName2WidgetID

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the widget id of a field from the plugin-definition by name.

The opposite of vsoWidgetGetRecParam

FUNCTION vsoPrmName2WidgetID(
recName :STRING;
paramName :STRING;
VAR outWidgetID :LONGINT) : BOOLEAN;
def vs.vsoPrmName2WidgetID(recName, paramName):
    return (BOOLEAN, outWidgetID)

Parameters

recName STRING
paramName STRING
outWidgetID LONGINT

Remarks

For this function to work, you need to use an empty string for the record name.

Version

Availability: from Vectorworks 2011