VS:Symbol

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Symbol places a symbol in the document at the specified coordinate location.

PROCEDURE Symbol(
symbolName :STRING;
pX,pY :REAL;
rotationAngle :REAL);
def vs.Symbol(symbolName, p, rotationAngle):
    return None

Parameters

symbolName STRING Name of symbol.
p REAL Coordinates of symbol insertion point.
rotationAngle REAL Rotation angle of symbol, in degrees.

Remarks

This doesn't work if VS:AngleVar is turned on.

Seems to set the documents active symbol definition [CMP]

Version

Availability: from All Versions