VS:SetViewMatrix

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets view matrix for layer or viewport object.

FUNCTION SetViewMatrix(
objectHandle :HANDLE;
offsetX,offsetY,offsetZ :REAL;
rotationXAng :REAL;
rotationYAng :REAL;
rotationZAng :REAL) : BOOLEAN;
def vs.SetViewMatrix(objectHandle, offset, rotationXAng, rotationYAng, rotationZAng):
    return BOOLEAN

Parameters

objectHandle HANDLE
offset REAL
rotationXAng REAL
rotationYAng REAL
rotationZAng REAL

Version

Availability: from VectorWorks10.5