VS:SetTextWidth

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTextWidth Sets the text wrapping margin width of the referenced text object.

A call to SetTextWidth automatically activates text wrapping.

PROCEDURE SetTextWidth(
theText :HANDLE;
widthDistance :REAL);
def vs.SetTextWidth(theText, widthDistance):
    return None

Parameters

theText HANDLE Handle to text object.
widthDistance REAL Text wrapping margin setting for text.

Example

VectorScript

PROCEDURE Example;

FUNCTION IncreaseTextWidth(h :HANDLE) :BOOLEAN;
BEGIN
SetTextWidth(h, GetTextWidth(h) * 1.2);
END;

BEGIN
ForEachObjectInLayer(IncreaseTextWidth, 2, 0, 4);
END;
RUN(Example);

Python


Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:GetTextWidth

VS Functions: [[VS:GetTextWidth]]