VS:SetTexSpacePartID

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTexSpacePartID sets the parent of the referenced texture space in an expanded object (walls or roofs).

Table - Texture Space Objects
Object Constant
Primary 0
Secondary 1
Tertiary 2
PROCEDURE SetTexSpacePartID(
textureSpace :HANDLE;
partID :INTEGER);
def vs.SetTexSpacePartID(textureSpace, partID):
    return None

Parameters

textureSpace HANDLE Handle to texture space.
partID INTEGER Part ID of texture space parent.

Remarks

Sets which part (0 = Primary, 1 = Secondary, 2 = Tertiary) of the object this space belongs to (for expanded walls and roofs).

Note: SetTexMapXXX routines replace the older SetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0