VS:SetTempToolHelpStr

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets a text to be used as help string for temp tool calls: RunTempTool, TrackObject, GetPt, GetPtL, GetPt3D, and GetPtL3D.


This function should be called prior to calling the tool.

The help string will be used for subsequent temp tool runs until changed.

PROCEDURE SetTempToolHelpStr(
helpString :STRING);
def vs.SetTempToolHelpStr(helpString):
    return None

Parameters

helpString STRING The help string for the next temp tool.

Example

VectorScript

PROCEDURE Test;
VAR h : HANDLE;
  
  FUNCTION CheckObjCallback(h : HANDLE) : BOOLEAN;
  BEGIN
     {any object is ok}
     CheckObjCallback := true;
  END;

BEGIN
SetTempToolHelpStr( 'Select any object' );
TrackObject( CheckObjCallback, h );
SetSelect( h );
END;
RUN( Test );

Python


Version

Availability: from Vectorworks 2010