VS:SetRoofEdge

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetRoofEdge sets the definition attributes of a roof edge for the referenced roof object.

PROCEDURE SetRoofEdge(
roofObject :HANDLE;
index :INTEGER;
vertexPtX,vertexPtY :REAL;
edgeAngle :REAL;
projectionDistance :REAL;
eaveHeightDistance :REAL);
def vs.SetRoofEdge(roofObject, index, vertexPt, edgeAngle, projectionDistance, eaveHeightDistance):
    return None

Parameters

roofObject HANDLE Handle to roof.
index INTEGER Index of roof edge.
vertexPt REAL Coordinates of roof edge vertex.
edgeAngle REAL Roof slope.
projectionDistance REAL Eave overhang.
eaveHeightDistance REAL Eave height.

Remarks

Vertices define the outline of the roof and its characteristics. Vertices must progress in a counter clock wise direction, when viewed from a top view, otherwise the roof cannot be built.

index: Indexs have values between 1 and NVertices (See GetRoofVertices()) edgePt: Coordinate point for this edge slope: pitch of this roof edge projection: eave overhang eaveHeight: eave height

Version

Availability: from VectorWorks8.0