VS:SetPrimaryDim

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetPrimaryDim sets the primary dimension options for single and dual dimensions.

PROCEDURE SetPrimaryDim(
h :HANDLE;
showValue :BOOLEAN;
boxText :BOOLEAN;
leader :STRING;
trailer :STRING;
precision :LONGINT);
def vs.SetPrimaryDim(h, showValue, boxText, leader, trailer, precision):
    return None

Parameters

h HANDLE Handle to dimension.
showValue BOOLEAN Display dimension value flag.
boxText BOOLEAN Display box around dimension text flag.
leader STRING Leader string.
trailer STRING Trailer string.
precision LONGINT Precision setting for displayed dimension value.

Remarks

Sets dimension values that are specific to the primary portion of a dual dimension. This procedure can also be used for non-dual dimensions.

[sd 8/18/98]

Example

VectorScript

SetPrimaryDim(dimHd,TRUE,FALSE,'Approx.','',64);

Python


Version

Availability: from MiniCAD7.0