VS:SetObjectAsSpanBreak

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets an object's span wall flag in it's break record.


Setting the flag to TRUE will force the object the center of the wall and set the offset position of the break record to reflect this.

Setting the flag to FALSE will unset the span wall flag, but no further updating to the object will occur.

The oject (objH) must be contained in wall (wallH) for the setting to succeed.

FUNCTION SetObjectAsSpanBreak(
objH :HANDLE;
wallH :HANDLE;
spanWallBreak :BOOLEAN) : BOOLEAN;
def vs.SetObjectAsSpanBreak(objH, wallH, spanWallBreak):
    return BOOLEAN

Parameters

objH HANDLE The handle of the object to update.
wallH HANDLE The handle of the wall cotainting the object referenced in objH.
spanWallBreak BOOLEAN Boolean value to set or unset the span wall flag for the object.

Return Value

True or False upon successfull setting of the flag


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2016