VS:SetObjectAsCornerBreak

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets an object's corner break flag in it's corner break record.


Setting the flag to TRUE will force the object into the closest end of the wall and set the offset position of the break record to reflect this.

Setting the flag to FALSE will unset the corner flag, but no further updating to the object will occur.

The object (objH) must be contained in wall (wallH) for the setting to succeed.

FUNCTION SetObjectAsCornerBreak(
objH :HANDLE;
wallH :HANDLE;
cornerBreak :BOOLEAN) : BOOLEAN;
def vs.SetObjectAsCornerBreak(objH, wallH, cornerBreak):
    return BOOLEAN

Parameters

objH HANDLE The handle of the object to update.
wallH HANDLE The handle of the wall containing the object referenced in objH.
cornerBreak BOOLEAN Boolean value to set or unset the cornerBreak flag for the object.

Return Value

True or False upon successfull setting of the flag.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2010