VS:SetLBItemTextColor

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the text color for the specified list browser item.

FUNCTION SetLBItemTextColor(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
redIndex :INTEGER;
greenIndex :INTEGER;
blueIndex :INTEGER) : BOOLEAN;
def vs.SetLBItemTextColor(dialogID, componentID, itemIndex, subItemIndex, redIndex, greenIndex, blueIndex):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
redIndex INTEGER the red component (0 - 255)
greenIndex INTEGER the green component (0 - 255)
blueIndex INTEGER the blue component (0 - 255)

Version

Availability: from VectorWorks12.0