VS:SetLBItemLineType

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified list browser item's line type.

FUNCTION SetLBItemLineType(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
lineType :LONGINT;
lineWeight :INTEGER) : BOOLEAN;
def vs.SetLBItemLineType(dialogID, componentID, itemIndex, subItemIndex, lineType, lineWeight):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
lineType LONGINT the line type internal index (reference number)
lineWeight INTEGER the line weight

Version

Availability: from Vectorworks 2015