VS:SetLBHierDispColumn

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function sets which column to display hierarchically in a list browser. This will only work on a text column. Items with dashes in the string value for the hierarchical column will be displayed hierarchically. This will work on items already entered. When new items are entered, this will need to be called again.

PROCEDURE SetLBHierDispColumn(
dialogID :LONGINT;
componentID :LONGINT;
columnID :INTEGER);
def vs.SetLBHierDispColumn(dialogID, componentID, columnID):
    return None

Parameters

dialogID LONGINT The id of the dialog.
componentID LONGINT The id of the list browser.
columnID INTEGER The index of the hierarchical column.

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:EnableLBHierDisplay

VS Functions: [[VS:EnableLBHierDisplay]]